如何在树莓派上使用OAK相机?

如何在树莓派上使用OAK相机?

▌硬件连接

不管你用的是树莓派3,还是树莓派4,我们推荐你将OAK相机接在USB3.0的口上。

▌启用 USB 设备

由于OAK是USB设备,因此为了在使用 udev 工具的系统上与之通信, 您需要添加udev规则以使设备可访问。

以下命令将向您的系统添加新的udev规则:

echo 'SUBSYSTEM=="usb", ATTRS{idVendor}=="03e7", MODE="0666"' | sudo tee /etc/udev/rules.d/80-movidius.rules
sudo udevadm control --reload-rules && sudo udevadm trigger

▌安装depthai

安装方式有两种,任选其一即可。(我们推荐1)
国外有用户做了两个视频教程:

大家也可以任选其一,跟着装depthai,都很简单。

  1. 下载镜像安装

下载OAK树莓派镜像:

(PS:百度网盘如果下载较慢,建议从sourceforge下载。)

我们准备了一个安装好OAK依赖的树莓派镜像。烧录完成后插入树莓派启动即可。

下载树莓派官方烧录工具

打开软件,选择我们的oak树莓派镜像和您要烧录进的内存卡,即可开始烧录。

启动成功后,打开命令行执行以下命令就可以运行oak:

cd depthai
python3 depthai_demo.py
  1. git拉取安装

depthai

git clone https://gitee.com/oakchina/depthai.git

depthai-python

git clone https://gitee.com/oakchina/depthai-python.git

depthai-experiments

git clone https://gitee.com/oakchina/depthai-experiments.git

安装依赖:

python3 -m pip install -r depthai/requirements.txt -i https://pypi.tuna.tsinghua.edu.cn/simple

执行以下命令:

python3 depthai/depthai_demo.py

▌使用示例

现在你可以查看depthai-examples里的示例,挑选感兴趣的示例来上手跑一遍了。

▌常见错误

在树莓派上,运行 sudo upgrade 后,在导入cv2的时候可能会出现 realloc(): invalid pointern Aborted 错误。我们也遇到了同样的问题,并且找到了解决方案 :

  • 通过运行 sudo apt install -y –allow-downgrades libc6=2.28-10+rpi1命令使libc6降级。
  • 通过运行 sudo curl -fL http://docs.luxonis.com/static/install_dependencies.sh | bash命令重新安装depthai依赖。

Tags: